Help

Historic Maps Site Help

Getting Started

System Requirements

In order to use the Map Explorer you will need to have the following system requirements:

Adobe Flash Player version 11.1.0 or greater. 

Firefox 1.1+, Internet Explorer 6.0+, Safari 1.0+, Google Chrome, or Opera